На главную... Продукты | Технологии | Классификаторы | Проекты | Скачать | Цены| Форум | Статьи | Обучение | Контакты

Проблема с установкой Панорамы под AstraLinux CE

Поиск  Пользователи  Правила  Войти
Форум » Linux » ГИС Панорама для Linux
Страницы: 1
RSS
Проблема с установкой Панорамы под AstraLinux CE
 
Попробовал поставить ГИС Карта 2005 SE (версия 11.14.1, для платформы "x64", ОС "Astra Linux Special Edition", релиз "Смоленск"), скаченную с Вашего сайта, под AstraLinux Common Edition, скаченную с сайта https://astralinux.ru/products/astra-linux-common-edition/ ...
Получил следующие сообщения:

root@astra:/home/guest/Panorama 11.14.1.5# dpkg -i panorama.deb
Выбор ранее не выбранного пакета panorama.
(Чтение базы данных … на данный момент установлено 146757 файлов и каталогов.)
Подготовка к распаковке panorama.deb …
Распаковывается panorama (11.14.1.5) …
dpkg: зависимости пакетов не позволяют настроить пакет panorama:
panorama зависит от libisc84 | libisc160, однако:
 Пакет libisc84 не установлен.
 Пакет libisc160 не установлен.

dpkg: ошибка при обработке пакета panorama (--install):
проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
panorama

Попробовал, всё-таки, запустить через startgis.bat

Получил ...

root@astra:/usr/Panorama11# ./startgis.bat
/usr/Panorama11/panorama.exe: error while loading shared libraries: libisc.so.84: cannot open shared object file: No such file or directory

Вопрос - что делать? и как всё-таки поставить и запустить...
Заранее благодарю!  :D  
 
Здравствуйте!

Необходимо выполнить команду установки неудовлетворенных зависимостей в системе, которая должна сначала установить недостающую библиотеку isc, а потом саму ГИС Панорама:
Код
sudo apt-get install -f 
Если установка ГИС Панорама все равно завершилась с ошибкой, значит данная версия ОС содержит версию библиотеки isc, отличную от требуемой ГИС Панорама.
В этом случае необходимо выполнить следующие действия:
  • установить пакет с библиотекой isc из состава ОС:
    Код
    sudo apt-get install <имя_пакета>

  • создать символическую ссылку в каталоге ГИС Панорама:
    Код
    sudo ln -s <путь_к_libisc_в_системе> /usr/Panorama11/libisc.so.84

 
Здравствуйте!
Аналогичное затруднение с Оператором.
Символьные ссылки не помогли. В системе установлен пакет ibisc.so.169.0.1


аrm@astrahan:~$ sudo ln -s /usr/lib/x86_64-linux-gnu/libisc.so.169.0.1 /usr/Operator12/libisc.so.160
arm@astrahan:~$ sudo ln -s /usr/lib/x86_64-linux-gnu/libisc.so.169.0.1 /usr/Operator12/libisc.so.84
arm@astrahan:~$ sudo ln -s /usr/lib/x86_64-linux-gnu/libisc.so.169.0.1 /usr/lib/x86_64-linux-gnu/libisc.so.84
arm@astrahan:~$ sudo ln -s /usr/lib/x86_64-linux-gnu/libisc.so.169.0.1 /usr/lib/x86_64-linux-gnu/libisc.so.160
arm@astrahan:~$ sudo dpkg -i Distrib/Operator/operator.deb
(Чтение базы данных … на данный момент установлено 203452 файла и каталога.)
Подготовка к распаковке Distrib/Operator/operator.deb …
Распаковывается operator (12.1.1.7) на замену (12.1.1.7) …
dpkg: зависимости пакетов не позволяют настроить пакет operator:
operator зависит от libisc84 | libisc160, однако:
 Пакет libisc84 не установлен.
 Пакет libisc160 не установлен.
 
Здравствуйте!
В данном случае необходимо выполнять установку ГИС Оператор с игнорированием неудовлетворенных зависимостей в системе. Для этого выполните установку пакета, например с помощью команды:
Код
sudo dpkg -i --ignore-depends=libisc84 operator.deb
 
Я добавил в список
Код
 /etc/apt/sources.list
Строку:
Код
deb https://mirror.yandex.ru/debian/ stretch main contrib non-free
Это репозиторий пакетов от debian9 stretch.
Далее команды:
Код
sudo apt install debian-archive-keyring dirmngr
sudo apt update
sudo apt-get install libisc160

Затем инсталляция Панорамы прошла без сбоев.

Собственно, инструкция с вики астры Подключение репозиториев Debian 9 "Stretch":
Изменено: Илья Юрченков - 26.12.2019 21:23:21
Страницы: 1
Читают тему (гостей: 1)



© КБ Панорама, 1991-2020

Регистрируясь или авторизуясь на форуме, Вы соглашаетесь с Политикой конфиденциальности