На главную... Продукты | Технологии | Классификаторы | Проекты | Скачать | Цены| Форум | Статьи | Обучение | Контакты

Множественные ошибки в GIS WebService SE

Поиск  Пользователи  Правила  Войти
Форум » Серверные приложения » GIS WebService
Страницы: 1
RSS
Множественные ошибки в GIS WebService SE, Множество ошибок и часть функционала сервиса не работает.
 
Здравствуйте, пытаюсь запустить GIS WebService SE, делаю все по инструкции. На главной странице следующая ошибка -



Доступ к данным файлам (название которых известно) неограничен, права на редактирование включены.
Далее, ошибка с данным текстом "socket_read() failed: Произошла ошибка при получении данных.".
На вкладке "Параметры службы", следующие ошибки:



Кнопки  "Подключение к базам данных" и "Состояние службы" не активны.
Делалось всё по инструкции.
У меня установлен php 8.3.2 и последние версии приложений с вашего сайта.
 
Добрый день!

У Вас не работает или не запущена служба GIS Application Service.
Для понимания, что происходит необходимо больше информации - например какая ОС, какой веб-сервер используется например IIS или nginx и тд, создаются ли логи в директории для ОС Windows C:\ProgramData\Panorama\appservice\LOG, для ОС Linux /var/Panorama/appservice/LOG/.
 
Цитата
Вячеслав Семеновых написал:
Добрый день!

У Вас не работает или не запущена служба GIS Application Service.
Для понимания, что происходит необходимо больше информации - например какая ОС, какой веб-сервер используется например IIS или nginx и тд, создаются логи в директории для ОС Windows C:\ProgramData\Panorama\appservice\LOG, для ОС Linux /var/Panorama/appservice/LOG/.
ОС Windows 10, веб-сервер IIS, логи создаются, вот последние записи:
">>>> 20240130 09:43:00 1fc8 Can`t get parameters for license, err_code = 3
>>>> 20240130 09:43:00 1fc8 Key verification error code = 0x80, guardant error code = 0x24
Лицензия на использование программы не найдена.
USB-ключ Guardant не найден ".
Каким я должен запустить службу GIS Application Service? В инструкции об этом не сказано.
 
Добрый день!

На нашем сайте в разделе документация для Windows в документе "GIS WebService SE ПАРБ.00160-01 Руководство системного программиста. Часть 1" в разделе "Запуск службы GIS Application Service на Windows" подробно описан порядок запуска службы:
https://gistoolkit.com/download/doc/giswebservicesedoc1.pdf#page=51&zoom=100,72,698
Вам при установке и настройке необходимо руководствоваться именно данным документом.
 
Цитата
Вячеслав Семеновых написал:
Добрый день!

На нашем сайте в разделе документация для Windows в документе "GIS WebService SE ПАРБ.00160-01 Руководство системного программиста. Часть 1" в разделе " Запуск службы GIS Application Service на Windows " подробно описан порядок запуска службы:
https://gistoolkit.com/download/doc/giswebservicesedoc1.pdf#page=51&zoom=100,72,698
Вам при установке и настройке необходимо руководствоваться именно данным документом.
Понял, спасибо, я использовал "Инструкция по установке и первичной настройке".
 
Версия ГИС Сервера 11.2.1.59
Версия GIS Web Service 15.5.4
Версия GIS Web Server 6.20.0

При подключении от Service к Серверу через пользователя/пароль в Service доступны слои с Сервера - все окей (зеленая галочка).
При настройке проектов в Server, добавлении слоев - все окей.
Но далее, при просмотре этах проектов/переключении между ними - слетает подключение Service к Серверу (появляется красный крестик).

Лечится это перезапуском Service.
Но как только начинаешь снова просмотр проектов/переключение между ними - слетает подключение Service к Серверу (появляется красный крестик).

Сравнивал файл appservice.xml (на Service), где прописываются параметры подключения Service к Серверу, до и после ошибки - файлы идентичные.

Подскажите, в чем может быть причина данной ошибки?
Ранее, на более старых версиях, при аналогичных настройках данной проблемы не наблюдалось.
Обновиться до самых актуальных версий на данный момент нет возможности.
Спасибо.
 
Цитата
Тимофей Буков написал:
Подскажите, в чем может быть причина данной ошибки?

Чтобы понять проблему необходим лог сервиса. Он находится в папке var/panorama/appservice/LOG/appservice.log в расширенном режиме записи. Для этого установите свойство "Ведение журнала ошибок" в "2" на закладке "параметры службы".

Также нужен расширенной log ГИС Сервера.
Активировать расширенный режим записи лога  для ГИС Сервера. Информация - Печать диагностических сообщений - Печатать.
var/panorama/gisservice/LOG/gisservice.log.
 
Здравствуйте, вы не могли бы вы сбросить 2-3 разных версий (или ссылки на них) пакетов для Гис веб сервиса для Linux (CentOS 7) старше 15.5.4.1144? На сайте в архивах таких версий нет. Почта ty7rite3@mail.ru. Обращался неоднократно на вашу почту - так ничего и не отправили. Номер ключа 48803.
Проблема в разрыве соединения сервиса с сервером, из-за чего веб сервер ничего «не видит».
15.5.4.1144 видит ключ, но разрывает соединение с Гис сервером.
15.2.4, 15.9.2 не видят ключ.
Последняя работала 14.5.7, но может быть будут промежуточные между ней и 15.5.4.1144
На версии 14.5.10. Все работает, ошибка разъединения ушла и лицензию видит. Но теперь веб сервер не видит файлы .map. Хотя они есть и в прошлых версиях отображались.
Просьба отправить для теста более старых версий, без запросов логов и тд. Тк ранее неоднократно я это все вам отправлял. Опытным путем ошибка уходит, но появляется другая. Задача - найти более-менее стабильную версию, не важно если она не будет самой актуальной.
Спасибо!
 
Цитата
Тимофей Буков написал:
Здравствуйте, вы не могли бы вы сбросить 2-3 разных версий (или ссылки на них) пакетов для Гис веб сервиса для Linux (CentOS 7) старше 15.5.4.1144? На сайте в архивах таких версий нет. Почта  ty7rite3@mail.ru . Обращался неоднократно на вашу почту - так ничего и не отправили. Номер ключа

Добрый день!

Техническая поддержка для лицензии закончилась 01.09.2024. Для использования актуальных версий необходимо продление технической поддержки.

На электронную почту выслали дистрибутив программы GIS WebService SE 15.8.1.12 x64 CentOS 7.2.1511
Страницы: 1
Читают тему (гостей: 1)



© КБ Панорама, 1991-2026

Регистрируясь или авторизуясь на форуме, Вы соглашаетесь с Политикой конфиденциальности